WordPress not supporting Internet Explorer 6

It looks as if the latest version of WordPress will not support users who are still running the IE6 browser, this follows several users who updated their WordPress version only to be greeted by a big red notice claiming that the browser is unsecure and asking them to upgrade to higher version of IE!

According to Jane Wells the WordPress UX Lead, “It has required increasingly complex code trickery to make the WordPress dashboard work in the IE6 browser, which was introduced 10 years ago and does not support current web standards.,”

This is an issue though, because despite being an older browser IE6 is still managing to hang on with almost twelve per cent of the global browser market still using IE6, but in China the market share is almost thirty five per cent!

Source [Read Write Web]